Пример формирования поднадзорного объекта для выгрузки в АСП:Шлюз

В примере используются следующие функции: СформироватьХозСубъект

Функция СформироватьПоднадзорного(Партнер, Контрагент, Фабрика)
	ПоднадзорныйОбъект	= Фабрика.Создать(Фабрика.Тип( ПространствоИмен(),"ПоднадзорныйОбъект"));
	
	ПоднадзорныйОбъект.Наименование = Партнер.Наименование;
	ПоднадзорныйОбъект.НаименованиеПолное = Партнер.Наименование; //#1
	
	ПоднадзорныйОбъект.Тип = 1; //#2
	//ПоднадзорныйОбъект.Комментарий 	= "";//Партнер.ДополнительнаяИнформация;
	ПоднадзорныйОбъект.Код = Партнер.Код;
	
	Результат = СформироватьХозСубъект(Контрагент,фабрика);
	Если ТипЗнч(Результат)= Тип("Строка") Тогда
		Возврат Результат;
	Иначе
		ПоднадзорныйОбъект.ХозСубъект = Результат;
	КонецЕсли;
	
	// Обычные формы //#3
	ПоднадзорныйОбъект.Адрес = УправлениеКонтактнойИнформацией.ПолучитьАдресИзКонтактнойИнформации(Контрагент, "Фактический");
	Если НЕ ЗначениеЗаполнено(ПоднадзорныйОбъект.Адрес) Тогда
		Сообщить("Необходимо заполнить фактический адрес контрагента: " + Партнер);
		Возврат Неопределено;
	КонецЕсли;
	
	Возврат ПоднадзорныйОбъект;
КонецФункции

#1 Заполнение полного наименования

#2 Заполнение типа поднадзорного

#3 Заполнение адреса