Различия

Здесь показаны различия между двумя версиями данной страницы.

Ссылка на это сравнение

Предыдущая версия справа и слева Предыдущая версия
шлюз_выгрузка:сформировать_поднадзорного [2018/08/02 15:43]
misha
шлюз_выгрузка:сформировать_поднадзорного [2018/08/02 16:03] (текущий)
misha
Строка 52: Строка 52:
 ++++ ++++
  
-++++3 Заполнение адреса+++++#3 Заполнение адреса
 | |
-На управляемых формах адрес ​Хоз. субъекта ​можно получить следующим способом ​+На управляемых формах адрес можно получить следующим способом ​
 <1c> <1c>
-Если ​Контрагент.КонтактнаяИнформация.Количество() > 0 Тогда +Если ​Партнер.КонтактнаяИнформация.Количество() > 0 Тогда 
- Для ​каждого Инф ​из Контрагент.КонтактнаяИнформация Цикл  + Для ​Каждого Инф ​Из Партнер.КонтактнаяИнформация Цикл  
- Если Инф.Тип = Перечисления.ТипыКонтактнойИнформации.Адрес И Инф.Вид = Справочники.ВидыКонтактнойИнформации.ЮрАдресКонтрагента Тогда //​Инф.Вид = Справочники.ВидыКонтактнойИнформации.ФактАдресКонтрагента + Если Инф.Тип = Перечисления.ТипыКонтактнойИнформации.Адрес И Инф.Вид = Справочники.ВидыКонтактнойИнформации.ФактАдресКонтрагента Тогда //​Инф.Вид = Справочники.ВидыКонтактнойИнформации.ЮрАдресКонтрагента  
-          ​ХозСубъект.Адрес = Инф.Представление;​+          ​ПоднадзорныйОбъект.Адрес = Инф.Представление;​
  Прервать;​  Прервать;​
  КонецЕсли;​  КонецЕсли;​
Строка 69: Строка 69:
 Для обычных форм это может быть: Для обычных форм это может быть:
 <1c> <1c>
-ХозСубъект.Адрес = УправлениеКонтактнойИнформацией.ПолучитьАдресИзКонтактнойИнформации(Контрагент, "​Юридический"​);​ +ПоднадзорныйОбъект.Адрес = УправлениеКонтактнойИнформацией.ПолучитьАдресИзКонтактнойИнформации(Партнер, "​Юридический"​);​ 
-Если НЕ ЗначениеЗаполнено(ХозСубъект.Адрес) Тогда +Если НЕ ЗначениеЗаполнено(ПоднадзорныйОбъект.Адрес) Тогда 
- Сообщить("​Необходимо заполнить юридический адрес контрагента:​ " + Контрагент); + Сообщить("​Необходимо заполнить юридический адрес контрагента:​ " + Партнер); 
  Возврат Неопределено;​  Возврат Неопределено;​
 КонецЕсли;​ КонецЕсли;​
Строка 77: Строка 77:
 или или
 <1c> <1c>
-ХозСубъект.Адрес = УправлениеКонтактнойИнформацией.ПолучитьАдресИзКонтактнойИнформации(Контрагент, "​Фактический"​);​ +ПоднадзорныйОбъект.Адрес = УправлениеКонтактнойИнформацией.ПолучитьАдресИзКонтактнойИнформации(Партнер, "​Фактический"​);​ 
-Если НЕ ЗначениеЗаполнено(ХозСубъект.Адрес) Тогда +Если НЕ ЗначениеЗаполнено(ПоднадзорныйОбъект.Адрес) Тогда 
- Сообщить("​Необходимо заполнить ​юридический адрес контрагента:​ " + Контрагент); + Сообщить("​Необходимо заполнить ​фактический адрес контрагента:​ " + Партнер); 
  Возврат Неопределено;​  Возврат Неопределено;​
 КонецЕсли;​ КонецЕсли;​
 </1c> </1c>
 ++++ ++++