Пример формирования хозяйствующего субъекта для выгрузки в АСП:Шлюз

Функция СформироватьХозСубъект(Контрагент,фабрика)
	
	ХозСубъект	= Фабрика.Создать(Фабрика.Тип( ПространствоИмен(),"ХозяйствующийСубъект"));
	
	ХозСубъект.Наименование 		= Контрагент.Наименование;
	ХозСубъект.НаименованиеПолное 	= Контрагент.НаименованиеПолное;
	Если Контрагент.Ссылка.Метаданные().Реквизиты.Найти("ЮридическоеФизическоеЛицо")=Неопределено Тогда //#1
		ЮрФизЛицо = "Физ";
	Иначе
		Если Контрагент.ЮридическоеФизическоеЛицо = Перечисления.ЮридическоеФизическоеЛицо.ЮридическоеЛицо Тогда //#1 
			ЮрФизЛицо = "Юр";                                                  	
		ИначеЕсли Контрагент.ЮридическоеФизическоеЛицо = Перечисления.ЮридическоеФизическоеЛицо.ФизическоеЛицо Тогда //#1 
			ЮрФизЛицо = "ИП";
		КонецЕсли;
	КонецЕсли;
	
	ХозСубъект.ЮрФизЛицо = ЮрФизЛицо;
	ХозСубъект.ИНН = Контрагент.ИНН; // Метаданные.Справочники.Контрагенты.Реквизиты.Найти("ИНН")<>Неопределено
	//ХозСубъект.ОГРН = "";
	ХозСубъект.Комментарий = "перенесено через XDTO";
	
	
	
	// Обычные формы //#2
	ХозСубъект.Адрес = УправлениеКонтактнойИнформацией.ПолучитьАдресИзКонтактнойИнформации(Контрагент, "Юридический");
	Если НЕ ЗначениеЗаполнено(ХозСубъект.Адрес) Тогда
		Сообщить("Необходимо заполнить юридический адрес контрагента: " + Контрагент); 
		Возврат Неопределено;
	КонецЕсли;	

	//ХозСубъект.Организация = Истина;  // Указывается, если выхружаемый Хоз. субъект является организацией
	Возврат ХозСубъект;
КонецФункции

#1 Заполнение поля ЮрФизЛицо

#2 Заполнение адреса