Различия

Здесь показаны различия между двумя версиями данной страницы.

Ссылка на это сравнение

Предыдущая версия справа и слева Предыдущая версия
Следующая версия
Предыдущая версия
шлюз_выгрузка:описание_типов [2019/11/09 18:50]
misha [Номенклатура]
шлюз_выгрузка:описание_типов [2020/04/21 09:07] (текущий)
misha [Маршрут]
Строка 284: Строка 284:
 ||Посредник|[[шлюз_выгрузка:​описание_типов#​ХозяйствующийСубъект|ХозяйствующийСубъект]]|[0..1]||| ||Посредник|[[шлюз_выгрузка:​описание_типов#​ХозяйствующийСубъект|ХозяйствующийСубъект]]|[0..1]|||
 ||РозничнаяРеализация|boolean|[0..1]||| ||РозничнаяРеализация|boolean|[0..1]|||
 +||КодСпецификации|string|[0..1]|Используется для «Производства». Код элемента справочника «Спецификации». Устанавливает отбор определенной спецификации при автоматическом формировании материалов.||
 ||Товары|[[шлюз_выгрузка:​описание_типов#​СтрокаНоменклатуры|СтрокаНоменклатуры]]|[0..*]||| ||Товары|[[шлюз_выгрузка:​описание_типов#​СтрокаНоменклатуры|СтрокаНоменклатуры]]|[0..*]|||
 ||Несоответствия|[[шлюз_выгрузка:​описание_типов#​СтрокаНоменклатуры|СтрокаНоменклатуры]]|[0..*]||| ||Несоответствия|[[шлюз_выгрузка:​описание_типов#​СтрокаНоменклатуры|СтрокаНоменклатуры]]|[0..*]|||
Строка 402: Строка 403:
 ||GTIN|string|[0..1]|| ||GTIN|string|[0..1]||
 ||Подкатегория|string|[0..1]|ГУИД подкатегории в системе Меркурий| ||Подкатегория|string|[0..1]|ГУИД подкатегории в системе Меркурий|
 +||СрокГодности|int|[0..1]|Срок годности ЧАС|
 +||СрокГодностиДень|int|[0..1]|Срок годности ДЕНЬ|
 +||СрокГодностиМесяц|int|[0..1]|Срок годности МЕСЯЦ|
 +||СрокГодностиГод|int|[0..1]|Срок годности ГОД|
 +||Фасовка|[[шлюз_выгрузка:​описание_типов#​Фасовка|Фасовка]]|[0..*]|Заполнение расширенной фасовки||
 ++++ ++++
 ++++Пример заполнения ++++Пример заполнения
Строка 423: Строка 429:
  НоменклатураХ.Скоропортящаяся = Ложь;  НоменклатураХ.Скоропортящаяся = Ложь;
  НоменклатураХ.Некачественная = Ложь;  НоменклатураХ.Некачественная = Ложь;
 + НоменклатураХ.Фасовка.Добавить(СформироватьФасовку(Номенклатура,​Фабрика));​
  НоменклатураХ.Комментарий = "​перенесено через XDTO";  НоменклатураХ.Комментарий = "​перенесено через XDTO";
   
Строка 639: Строка 646:
 ||Артикул|string|[0..1]||| ||Артикул|string|[0..1]|||
 ||Маркировки|string|[0..1]||| ||Маркировки|string|[0..1]|||
 +||Фасовка|[[шлюз_выгрузка:​описание_типов#​Фасовка|Фасовка]]|[0..*]|Таблица для расширенного заполнения фасовки.||
 +||КодСпецификации|string|[0..1]|Используется для «Производства». Код элемента справочника «Спецификации». Устанавливает отбор определенной спецификации при автоматическом формировании материалов.||
  
 Строка **Маркировок** имеет следующую структуру:​ **УровеньУпаковки:​КлассМаркировки:​Маркировка**. Доступные **классы** маркировки:​ UNDEFINED, BN, SSCC, EAN8, EAN13, EAN128, BUNDLE. **Уровень упаковки** принимает значения:​ Строка **Маркировок** имеет следующую структуру:​ **УровеньУпаковки:​КлассМаркировки:​Маркировка**. Доступные **классы** маркировки:​ UNDEFINED, BN, SSCC, EAN8, EAN13, EAN128, BUNDLE. **Уровень упаковки** принимает значения:​
Строка 687: Строка 696:
 ||Количество|double|[1..1]||| ||Количество|double|[1..1]|||
 ||Кратность|double|[1..1]|| ||Кратность|double|[1..1]||
 +||Спецификация|[[шлюз_выгрузка:​описание_типов#​СправочникСпецификация|СправочникСпецификация]]|[0..1]|Структура,​ содержащая код элемента справочника "​Спецификации",​ а также наименование и код подразделения. Если данное поле заполнено,​ стока спецификации будет подбираться только при явном указании данной спецификации в производственном документе. Если По коду не найдена спецификация в справочнике,​ она будет создана,​ если заполнено наименование. Если заполнен код подразделения спецификации,​ она будет закреплена за определенным подразделением.|
 +||КодПодразделения|string|[0..1]|Код подразделения организации. Данное поле Игнорируется,​ если заполнен КодСпецификации. Если поле заполнено,​ стока спецификации будет подбираться только для производственных документов по указанному подразделению.|
 ++++ ++++
 ++++Пример заполнения ++++Пример заполнения
Строка 699: Строка 710:
  СтрокаСпецификации.Период = ТекущаяДата();​  СтрокаСпецификации.Период = ТекущаяДата();​
  Возврат СтрокаСпецификации;​  Возврат СтрокаСпецификации;​
 +Конецфункции
 +
 +
 +</1c>
 +++++
 +----
 +====СправочникСпецификация====
 +++++Свойства
 +|
 +||**Имя**|**Тип**|**Обяз.**|**Описание**||
 +||Код|string|[1..1]|||
 +||Наименование|string|[0..1]|Наименование спецификации.||
 +||КодПодразделения|string|[0..1]|Код подразделения (производственной площадки) организации. Если заполнен код подразделения спецификации,​ она будет закреплена за определенным подразделением.||
 +
 +++++
 +++++Пример заполнения
 +|
 +<1c>
 +Функция СоздатьСправочникСпецификация(Товар,​Строка,​Фабрика)
 + СправочникСпецификация = Фабрика.Создать(Фабрика.Тип(ПространствоИмен(),"​СправочникСпецификация"​));​
 + СправочникСпецификация.Код = "​123";​
 + СправочникСпецификация.Наименование = "​Наименование элемента в справочнике";​
 + СправочникСпецификация.КодПодразделения = "​КодПодразделения"; ​
 + Возврат СправочникСпецификация;​
 Конецфункции Конецфункции
  
Строка 1068: Строка 1103:
 ---- ----
  
 +====Маркировка====
 +Данные одной маркировки. ​
 +++++Свойства
 +|
 +||**Имя**|**Тип**|**Обяз.**|**Описание**||
 +||Класс|string|[1..1]|Список допустимых значений класса:​ UNDEFINED, BN, SSCC, EAN8, EAN13, EAN128, BUNDLE. Если класс не задан или переданная строка не входит в обозначенный список,​ подставляется значение UNDEFINED.||
 +||Маркировка|string|[1..1]|Строка,​ содержащая маркировку||
 +++++
 +++++Пример заполнения
 +|
 +<1c>
 +Функция СформироватьМаркировку(Фасовка,​ Фабрика)
 + Маркировка ​ = Фабрика.Создать(Фабрика.Тип(ПространствоИмен(),"​Маркировка"​));​
 + Маркировка.Класс ​ = //​UNDEFINED,​ BN, SSCC, EAN8, EAN13, EAN128, BUNDLE;
 + Маркировка.Маркировка = //​Маркировка;​
 + Возврат Фасовка;​
 +КонецФункции
 +</1c>
 +++++
 +----
 +
 +
 +====Фасовка====
 +Данные одного уровня фасовки. Используется для передачи фасовки в строке товара ([[шлюз_выгрузка:​описание_типов#​СтрокаНоменклатуры|СтрокаНоменклатуры]]). ​
 +++++Свойства
 +|
 +||**Имя**|**Тип**|**Обяз.**|**Описание**||
 +||Уровень|int|[0..1]|уровень упаковки от 1 до 6, где: 1 - Внутренний уровень;​ 2 - Потребительский уровень;​ 3 - Промежуточный уровень;​ 4 - Торговый уровень;​ 5 - Дополнительный уровень;​ 6 - Транспортный (Логистический) уровень.||
 +||Упаковка|string|[0..1]|Наименование или ГУИД упаковки,​ соответствующие классификатору упаковок системы Меркурий.||
 +||Количество|int|[0..1]|Количество упаковок в данном уровне фасовки.||
 +||Маркировки|[[шлюз_выгрузка:​описание_типов#​Маркировка|Маркировка]]|[0..*]|Список маркировок на данном уровне фасовки.||
 +++++
 +++++Пример заполнения
 +|
 +<1c>
 +Функция СформироватьФасовку(Номенклатура,​ Фабрика)
 + Фасовка = Фабрика.Создать(Фабрика.Тип(ПространствоИмен(),"​Фасовка"​));​
 + Фасовка.Уровень ​    = //?​1,​2,​3,​4,​5,​6;​
 + Фасовка.Упаковка ​     = //Гуид или наименование упаковки;​
 + Фасовка.Количество ​    = //​Номенклатура.Фасовка.Количество;​
 + Фасовка.Маркировки.Добавить(СформироватьМаркировку);​
 +
 + Возврат Фасовка;​
 +КонецФункции
 +</1c>
 +++++
 +
 +----
 +
 +====Маршрут====
 +Справочник "​Маршруты"​ предназначен для выгрузки маршрутов доставки из учетной системы в АСП.Шлюз,​ группировки документов по Маршрутам,​ упрощения печати и отправки на регистрацию всех документов маршрута одновлеменно.
 +++++Свойства
 +|
 +||**Имя**|**Тип**|**Обяз.**|**Описание**||
 +||КодЗагрузки|string|[1..1]|уникальный код для связи с справочником маршрутов АСП.Шлюз ||
 +||Наименование|string|[1..1]|Наименование маршрута ||
 +||Группа|[[шлюз_выгрузка:​описание_типов#​Маршрут|Маршрут]]|[0..*]| ||
 +++++
 +++++Пример заполнения
 +|
 +<1c>
 +&​НаСервере
 +Процедура ДозаполнитьПоляДокумента(Документ,​ Правило,​ ДокументХдто,​ Фабрика)
 +
 +...  ​
 + ДокументХдто.Маршрут = СформироватьМаршрут(Документ,​ Фабрика);​
 +
 +КонецПроцедуры
 +&​НаСервере
 +Функция СформироватьМаршрут(Документ,​ Фабрика)
 + Маршрут = Фабрика.Создать(Фабрика.Тип(ПространствоИмен(),"​Маршрут"​));​
 + Маршрут.КодЗагрузки = "​01";​ // уникальный код для связи с справочником маршрутов АСП.Шлюз
 + Маршрут.Наименование = "​Тест маршрут №1";
 + ГруппаМаршрутов = Фабрика.Создать(Фабрика.Тип(ПространствоИмен(),"​Маршрут"​));​
 + ГруппаМаршрутов.КодЗагрузки = "​Г01";​
 + ГруппаМаршрутов.Наименование = "​Тест группа маршрутов №1";
 + Маршрут.Группа = ГруппаМаршрутов;​
 +
 + Возврат Маршрут;​
 +КонецФункции
 +
 +</1c>
 +++++
 +
 +----